Home / Forums / PGSuper Support / Installation and Setup / Cannot connect to Internet/FTP libraries from work, but can from home

Cannot connect to Internet/FTP libraries from work, but can from home


4 replies [Last post]
wilmiester
Offline
Joined: 05/11/2015

Hello all and thanks in advance,

Question: We cannot get PGSuper to reach out and get live Internet content while on our work network even with local firewall disabled, but we take the same laptop home and can access content as expected. What do we need to configure on our network (Ports, routes, etc) to allow it to work?

Detailed info

Win 7 sp1 64bit
User has admin rights
IE11
PGSuper 2.8.2
TxDOT

New machine build, all Win updates. No association to our domain at all, other than leveraging our network (path to Internet). When trying to configure PGSuper > Use Libraries and templates published on the local file system, Network or Internet > Select TxDOT

"An error occured while accessing the list of publishers".

If I edit the TxDOT preset, it says "unable to find catalog file: /pub/txdot-info/brg/pgsuper/PGSuperPackages.ini on the server." I can then see the server type, set to Internet FTP and the URL set to the following: "ftp://ftp.dot.state.tx.us/pub/txdot-info/prg/pgsuper/"

If I copy/paste that same URL into a browser, I'm presented with an FTP directory for that path.

So I can browse to it, but the application can't get there.....while on my work network. If I take it home, it works just fine. So again, what do we need to configure on our network (Ports, routes, etc) to allow it to work?

Many thanks,

Willis

johnpaul7784
Offline
Joined: 12/21/2016
I think you should have to

I think you should have to contact your cable provider so that he can resolve the issue.

John Paul

johnpaul7784
Offline
Joined: 12/21/2016
Well, I think it may be the

Well, I think it may be the signal issues if you are using the wireless internet service. I am using and I have never face such type of issues.

Pickings
Offline
Joined: 01/23/2009
A possible solution:

We have had several users with similar problems and have not been able to find a 100% solution. The problem might be due to "Public" and "Private" network settings in Windows, but I just don't know for sure.

In the meantime, we have set up a TxDOT mirror site at PGSuper.com that appears to work for most users. Instructions on how to set up PGSuper can be found at:
http://www.pgsuper.com/content/txdot

Richard Pickings, P.E.
BridgeSight Inc.

Pickings
Offline
Joined: 01/23/2009
Lots of things that can cause

Lots of things that can cause this, but my best guess is that you have some sort of firewall/security appliance on your company network. I would get with your IT staff, put the device in logging mode, try to connect with PGSuper to the ftp site, and then browse the firewall log to see if it is causing the issue. Please post back if you find the problem so others can learn from your experience.

PGSuper should be talking through the normal ftp ports 20 or 21

Richard Pickings, P.E.
BridgeSight Inc.